获取中...

-

Just a minute...

题目传送

  • 题目描述:

    There is a hill with n holes around. The holes are signed from 0 to n-1.

    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

    InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
    OutputFor each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.

Sample Input

2
1 2
2 2

Sample Output

NO
YES
  • 题目思路:
    只需要判断m和n的最大公约数是否等于1即可,不等于一则永远抓不到;

  • 代码:

    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    /*************************************************************************
    > File Name: HDU-1222.cpp
    > Author: sunowsir
    ************************************************************************/

    #include<bits/stdc++.h>
    using namespace std;

    int gcd(int a,int b){
    return b==0? a:gcd(b , a%b);
    }

    int main(){
    int m,n,N;
    cin>>N;
    while(N--){
    cin>>m>>n;
    if(gcd(m,n)!=1) cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
    }
    return 0;
    }
相关文章
评论
分享
  • HDU-1276

    题目描述 某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行一至三报数,凡报到三的出列,剩下的向小序号方向靠拢,继续从头开...

    HDU-1276
  • POJ-1979

    原题目:DescriptionThere is a rectangular room, covered with square tiles. Each tile is colored either red or black. A m...

    POJ-1979
  • Codeforces-787a

    题目传送 题目思路:拓展欧几里德:$$ax+b=cy+d; <=> ax+cy=d-b;$$ 代码: 12345678910111213141516171819202122232425...

    Codeforces-787a
  • HDU-1072

    题目描述:首先输入一个N;代表测试数据的个数;然后每个测试数据的开头第一行输入一个n和一个命令(FIFO或FILO<就是先进先出或先进后出>)然后是该测试数据的n行,每行包括“IN”加一个数字(代表入栈或入队)或者一个“...

    HDU-1072
  • HDU - 2072

    题目传送 Sample Input 1you are my friend # Sample Output 14 思路: 利用STL的set,但是需要注意字符串的处理,利用set的特性,建立一个中间字符串变量tmp,把当前单...

    HDU - 2072
  • BASH杂记

    BASH杂记
  • 八大排序算法总结

    直接插入排序算法 概述直接插入排序算法在逻辑上将整体数据分为两部分,一部分是已排序部分,另一部分是待排序部分 。排序的过程是:在待排序部分逐步的拿出一个元素,将其插入到已排序部分中合理的位置 。 适用场景插入排序在对几乎已经排好序的数...

    八大排序算法总结
  • hexo低成本搭建静态网页博客

    引言好多同学有写博客的习惯,也有各大例如csd、简等博客平台。但是这些平台毕竟是盈利平台,无法做到对自己的博客完全掌控,有一丝丝的不爽快。想要DIY一下几乎不可能。在这里推荐同学们自己动手丰衣足食。 准备知识 github最基本的使用...

    hexo低成本搭建静态网页博客
  • CPU信息获取

    准备知识 /proc文件系统是一个伪文件系统,该文件系统中存储着内核控制相关信息,通俗点说就是这个目录是虚拟的,它受内核直接控制,存储与内核控制相关的数据,与其他目录不同的是/proc目录不是真实存储在硬盘中的,它的数据存储在内存...

    CPU信息获取
  • BASH脚本实现素数线性筛

    知识准备 for循环12345678910111213141516171819202122232425for i in `seq 1 10`;do echo ${i}done#执行结果---------12345...

    BASH脚本实现素数线性筛
Please check the parameter of comment in config.yml of hexo-theme-Annie!